Commit 5c2737a9 authored by thomas.forbriger's avatar thomas.forbriger
Browse files

[FIX] (gremlin): librefpar replaces librefread

This is a legacy commit from before 2015-03-01.
It may be incomplete as well as inconsistent.
See COPYING.legacy and README.history for details.

applies to subdirectory tools too
parent 192c0ddc
......@@ -30,6 +30,7 @@
# 10/01/2010 V1.4 libgin.a must be compiled before gremlin is going to
# be linked
# 14/01/2011 V1.5 call cxx/Makefile in top-level targets
# 10/11/2014 V1.6 librefpar replaces librefread
#
# ============================================================================
#
......@@ -173,8 +174,8 @@ package: $(TF_MAKEPKG)
fullpackage: $(TF_MAKEPKG)
$(MAKE) -f $< \
PACKAGE=gremlinwithlibs \
PACKAGEEXPORT="trunk/src/green/gremlin1:src trunk/src/synt/ref/refmet/sub:contrib/refread" \
PACKAGETARGETS="contrib/refread:all src:all" \
PACKAGEEXPORT="trunk/src/green/gremlin1:src" \
PACKAGETARGETS="src:all" \
PACKAGELIBS="libtime libgrrefsub libwrefsub librefpar \
libsff libsffu libtf \
libaff libgsexx libdatrwxx libfapidxx libfourier libsffxx \
......
......@@ -30,13 +30,10 @@ Dependencies
required libraries:
libgin:
will be compiled by the Makefile in subdirectory libs
libtf, libgrrefsub (only for gremlin), libwrefsub (only for wgremlin):
libtf, librefpar, libgrrefsub (only for gremlin),
libwrefsub (only for wgremlin):
are available from directory src/libs
just call 'make install' in directory src/libs of your working copy
librefread:
is available in directory src/synt/ref/refmet
just call 'make librefread.a' in directory src/synt/ref/refmet of your
working copy
libpgplot:
is expected to be installed from external
libblas, liblapack:
......
......@@ -70,11 +70,11 @@
# polex requires:
# libtf
# moche requires:
# libtf, librefread
# libtf, librefpar
# moshift, moval, motab, mops, clemo, and splimo require:
# libgin, libtf
# mocon requires:
# libtf, librefread, libgin
# libtf, librefpar, libgin
# mop and pmotra require:
# libgin, libtf, libpgplot
# mocoxx and grestf require:
......@@ -84,13 +84,9 @@
# is available from directory src/green/gremlin1
# just call 'make libraries' in directory src/green/gremlin1 of your
# working copy
# libtf, libtfxx, libaff, libfourierxx:
# libtf, libtfxx, libaff, libfourierxx, librefpar:
# are available from directory src/libs
# just call 'make install' in directory src/libs of your working copy
# librefread:
# is available in directory src/synt/ref/refmet
# just call 'make librefread.a' in directory src/synt/ref/refmet of your
# working copy
# libpgplot:
# is expected to be installed from external
#
......@@ -98,6 +94,7 @@
# 09/02/2010 V1.0 Thomas Forbriger
# 10/11/2010 V1.1 only grereso depends on libnumrec
# 13/11/2010 V1.2 moved grereso to disan
# 10/11/2014 V1.3 librefpar replaces librefread
#
# ============================================================================
#
......@@ -180,13 +177,13 @@ polex: %: %.o
$(FC) -o $@ $^ $(FFLAGS) -ltf $(LDFLAGS)
moche: %: %.o
$(FC) -o $@ $^ $(FFLAGS) -lrefread -ltf $(LDFLAGS)
$(FC) -o $@ $^ $(FFLAGS) -lrefpar -ltf $(LDFLAGS)
moshift moval motab mops clemo splimo: %: %.o
$(FC) -o $@ $^ $(FFLAGS) -lgin -ltf $(LDFLAGS)
mocon: %: %.o
$(FC) -o $@ $^ $(FFLAGS) -lgin -lrefread -ltf $(LDFLAGS)
$(FC) -o $@ $^ $(FFLAGS) -lgin -lrefpar -ltf $(LDFLAGS)
mop pmotra: %: %.o
$(FC) -o $@ $^ $(FFLAGS) -lgin -ltf \
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment