Commit f5d4b728 authored by Florian Wittkamp's avatar Florian Wittkamp
Browse files

Compatibility to newest LAMA version

No backward compatibility to LAMA versions older than 29.09.2016, due to change within the methods of dmemo::BlockDistribution.
parent 2f147e5a
......@@ -11,7 +11,9 @@ Documentation:
- Type `doxygen` in `doc/`
Requierment:
- Library [LAMA](https://www.libama.org)
- Library [LAMA](https://www.libama.org) (Development-Version)
- Compiler with C++11 support
Tested with g++ (4.9.3).
Tested with:
- Compiler: g++ (4.9.3), clang++ (3.9)
- MPI: OpenMPI (1.7.2, 1.10.0)
......@@ -153,8 +153,7 @@ void derivatives( lama::SparseMatrix<ValueType>& A,
IndexType numSecondary = globalSize - secondaryIndex;
int lb, ub;
dmemo::BlockDistribution::getRange( lb, ub, dist->getGlobalSize(), myRank, numRanks );
ub += 1; // for right range indexing
dmemo::BlockDistribution::getLocalRange( lb, ub, dist->getGlobalSize(), myRank, numRanks );
size = dist->getLocalSize(); //getGlobalSize();
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment