Commit 2863d594 authored by julian.gethmann's avatar julian.gethmann
Browse files

Fix update issues

* installed is no longer supported
* some fixes in handlers
parent a82feb4d
......@@ -2,7 +2,7 @@
# https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux
- name: install dependencies
dnf:
state: installed
state: present
name: "{{ item }}"
with_items:
- rpcbind
......
---
- name: install fitting for Python 3
dnf: state=installed name={{ item }}
become: yes
dnf:
state: present
name: "{{ item }}"
with_items:
- python3-scipy
- python3-scikit-learn
......@@ -9,8 +11,11 @@
when: ansible_distribution == 'Fedora'
- name: install fitting via pip3
pip: executable=pip3 state=installed name={{ item }}
become: yes
pip:
executable: pip3
state: present
name: "{{ item }}"
with_items:
- iminuit
# - kafe
......
......@@ -2,7 +2,7 @@
- name: Software for dependency installation
dnf:
name: "{{ item }}"
state: installed
state: present
become: yes
with_items:
- gcc
......@@ -20,7 +20,7 @@
- name: "Install Python stack for scientific purposes (Distribution)"
package:
name: "{{ item }}"
state: installed
state: present
become: yes
with_items:
- "{{ python2pkg }}"
......@@ -43,7 +43,7 @@
- name: install pip packages Python 2
pip:
name: "{{ item }}"
state: installed
state: present
become: yes
with_items: "{{python2pip}}"
......@@ -60,6 +60,6 @@
pip:
executable: pip3
name: "{{ item }}"
state: installed
state: present
become: yes
with_items: "{{python3pip}}"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment