Commit 2887c8f5 authored by julian.gethmann's avatar julian.gethmann

Add support for different elegant/sdds versions depending on OS version

parent b8040dd0
...@@ -2,9 +2,10 @@ ...@@ -2,9 +2,10 @@
- name: install elegant - name: install elegant
become: yes become: yes
dnf: dnf:
name: "http://www.aps.anl.gov/Accelerator_Systems_Division/Accelerator_Operations_Physics/downloads/elegant-{{ version }}.{{ ansible_distribution|lower }}.{{ ansible_distribution_major_version }}.mpich.{{ ansible_architecture }}.rpm" name: "http://www.aps.anl.gov/Accelerator_Systems_Division/Accelerator_Operations_Physics/downloads/elegant-{{ item.value }}.{{ ansible_distribution|lower }}.{{ ansible_distribution_major_version }}.mpich.{{ ansible_architecture }}.rpm"
state: present state: present
when: ansible_distribution == 'Fedora' when: ansible_distribution == 'Fedora' and ansible_distribution_major_version|int == item.key|int
with_dict: "{{ ele_version }}"
tags: elegant tags: elegant
- name: copy the rpnl definitions - name: copy the rpnl definitions
...@@ -34,8 +35,7 @@ ...@@ -34,8 +35,7 @@
dnf: dnf:
name: "{{ item }}" name: "{{ item }}"
state: present state: present
with_items: with_items: "{{ preSDDSdev }}"
- preSDDSdev
when: ansible_distribution == 'Fedora' when: ansible_distribution == 'Fedora'
tags: tags:
- elegant - elegant
...@@ -44,9 +44,10 @@ ...@@ -44,9 +44,10 @@
- name: install SDDSToolKit - name: install SDDSToolKit
become: yes become: yes
dnf: dnf:
name: "http://www.aps.anl.gov/Accelerator_Systems_Division/Accelerator_Operations_Physics/downloads/SDDSToolKit-{{ sddstk_version }}.{{ ansible_distribution|lower }}.{{ ansible_distribution_major_version }}.{{ ansible_architecture }}.rpm" name: "http://www.aps.anl.gov/Accelerator_Systems_Division/Accelerator_Operations_Physics/downloads/SDDSToolKit-{{ item.value }}.{{ ansible_distribution|lower }}.{{ ansible_distribution_major_version }}.{{ ansible_architecture }}.rpm"
state: present state: present
when: ansible_distribution == 'Fedora' when: ansible_distribution == 'Fedora' and ansible_distribution_major_version|int == item.key|int
with_dict: "{{ sddstk_version }}"
tags: tags:
- elegant - elegant
- sdds - sdds
--- ---
version: 33.1.1-1 ele_version:
# sddstk_version: 3.5.1-1 # 26 25: 33.1.1-1
sddstk_version: 3.5-1 # 25 26: 33.1-1
sddstk_version:
25: 3.5-1
26: 3.5.1-1
oagtcltk_version: 1.24-1 oagtcltk_version: 1.24-1
defns_path: /usr/local/share/defns.rpn defns_path: /usr/local/share/defns.rpn
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment