Commit 14b50899 authored by Jannick Wolters's avatar Jannick Wolters
Browse files

updated runner to use different image

parent 157cc509
image: ubuntu:18.04
image: conanio/gcc9
stages:
- build
......@@ -10,8 +10,8 @@ build:
paths:
- code/bin
script:
- apt-get update
- DEBIAN_FRONTEND=noninteractive apt-get install -y g++ cmake libopenmpi-dev libblas-dev liblapack-dev git libvtk7.1 ninja-build
- sudo apt-get update
- sudo DEBIAN_FRONTEND=noninteractive apt-get install -y libopenmpi-dev libblas-dev liblapack-dev git libvtk7-dev ninja-build
- git submodule update --init --recursive
- cd code/build/debug
- cmake -G Ninja -DCMAKE_BUILD_TYPE=Debug -DBUILD_TESTING=True -DCMAKE_EXPORT_COMPILE_COMMANDS=True ../../
......
......@@ -10,8 +10,8 @@ TBD
## Build
### Required dependencies
- Compiler with C++20 support
- cmake >= v3.5
- Compiler with C++20 support (e.g. g++ v9)
- cmake >= v3.12.4
- LAPACK
- OpenMP
- MPI
......@@ -24,8 +24,7 @@ Note that an **active internet connection is required for the first build** in o
For the first build only, download all submodules:
```bash
git submodule init
git submodule update
git submodule update --init --recursive
```
### Compile the code
......
cmake_minimum_required( VERSION 3.5 )
cmake_minimum_required( VERSION 3.12.4 )
project( RTSN LANGUAGES CXX VERSION 0.0.1 )
set( CMAKE_CXX_STANDARD 20 )
set( CMAKE_CXX_STANDARD_REQUIRED ON )
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment