Commit 25319c4f authored by gj4210's avatar gj4210 👽
Browse files

Merge branch 'new_interface' of git.scc.kit.edu:scc-net/net-suite/net-suite into new_interface

parents 5419157c 1ede43a4
default:
image: debian-buster:latest
before_script:
## dependencies
- curl -sL https://deb.nodesource.com/setup_11.x | bash -
- apt-get install -y nodejs python3-requests
- apt-get update -y
- test -e /etc/apt/sources.list.d/nodesource.list || curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
- test -e /etc/apt/sources.list.d/nodesource.list || echo 'deb https://deb.nodesource.com/node_13.x buster main' > /etc/apt/sources.list.d/nodesource.list
- 'which npm || (apt-get update -y && apt-get install -y nodejs)'
- apt-get install python3-requests
- cd frontend/
- cp netvs.config.js.example netvs.config.js
- npm install
......@@ -10,7 +15,7 @@ before_script:
## Deployment
- 'which ssh-agent || ( apt-get update -y && apt-get install openssh-client -y )'
- 'which ssh-agent || ( apt-get install openssh-client -y )'
- eval $(ssh-agent -s)
- echo "$SSH_PRIVATE_KEY" | tr -d '\r' | ssh-add -
- mkdir -p ~/.ssh
......
This diff is collapsed.
......@@ -8,42 +8,42 @@
"lint": "vue-cli-service lint"
},
"dependencies": {
"@fortawesome/fontawesome-svg-core": "^1.2.14",
"@fortawesome/free-regular-svg-icons": "^5.7.1",
"@fortawesome/free-solid-svg-icons": "^5.7.1",
"@fortawesome/vue-fontawesome": "^0.1.5",
"ajv": "^6.8.1",
"axios": "^0.19.0",
"bootstrap": "^4.3.1",
"bootstrap-vue": "^2.1.0",
"@fortawesome/fontawesome-svg-core": "^1.2.27",
"@fortawesome/free-regular-svg-icons": "^5.12.1",
"@fortawesome/free-solid-svg-icons": "^5.12.1",
"@fortawesome/vue-fontawesome": "^0.1.9",
"ajv": "^6.12.0",
"axios": "^0.19.2",
"bootstrap": "^4.4.1",
"bootstrap-vue": "^2.7.0",
"http-proxy-middleware": "^0.19.1",
"i": "^0.3.6",
"node-sass": "^4.13.1",
"npm": "^6.13.6",
"popper.js": "^1.14.7",
"sass-loader": "^7.1.0",
"swagger-ui": "^3.24.3",
"popper.js": "^1.16.1",
"sass-loader": "^7.3.1",
"swagger-ui": "^3.25.0",
"v-debounce": "^0.1.2",
"vue": "^2.6.0",
"vue-awesome": "^3.4.0",
"vue-axios": "^2.1.4",
"vue": "^2.6.11",
"vue-awesome": "^3.5.4",
"vue-axios": "^2.1.5",
"vue-ctk-date-time-picker": "^2.4.0",
"vue-router": "^3.0.1",
"vue-virtual-scroller": "^1.0.0-beta.4",
"vuex": "^3.1.1"
"vue-router": "^3.1.6",
"vue-virtual-scroller": "^1.0.0-rc.2",
"vuex": "^3.1.3"
},
"devDependencies": {
"@vue/cli-plugin-babel": "^3.2.0",
"@vue/cli-plugin-eslint": "^3.2.0",
"@vue/cli-service": "^3.7.0",
"babel-eslint": "^10.0.1",
"css-loader": "^2.1.0",
"eslint": "^5.8.0",
"eslint-plugin-vue": "^5.0.0-0",
"@vue/cli-plugin-babel": "^3.12.1",
"@vue/cli-plugin-eslint": "^4.2.3",
"@vue/cli-service": "^4.2.3",
"babel-eslint": "^10.1.0",
"css-loader": "^2.1.1",
"eslint": "^5.16.0",
"eslint-plugin-vue": "^5.2.3",
"style-loader": "^0.23.1",
"vue-loader": "^15.6.2",
"vue-template-compiler": "^2.6.0",
"webpack-cli": "^3.2.3"
"vue-loader": "^15.9.1",
"vue-template-compiler": "^2.6.11",
"webpack-cli": "^3.3.11"
},
"eslintConfig": {
"root": true,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment