Commit 5934aaa3 authored by julian.gethmann's avatar julian.gethmann

Make setup.py compatible with Python 2.7 and PyScaffold 2.5

parent 7ace0f45
......@@ -19,15 +19,16 @@ entry_points = """
# For example:
# fibonacci = cassandra.skeleton:run
"""
if sys.version_info <= (3,):
requires = ['pyscaffold==2.5.10']
else:
requires = ['pyscaffold>=3.0a0,<3.1a0']
def setup_package():
needs_sphinx = {'build_sphinx', 'upload_docs'}.intersection(sys.argv)
sphinx = ['sphinx'] if needs_sphinx else []
setup(
setup_requires=['pyscaffold>=3.0a0,<3.1a0'] + sphinx,
entry_points=entry_points,
use_pyscaffold=True)
setup(setup_requires=requires + sphinx, entry_points=entry_points, use_pyscaffold=True)
if __name__ == "__main__":
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment